Android Studio

热议话题Instant App

Android Studio 实战秘籍 | Android Studio 使用经验

项目不能编译,总提示设备版本过低

用户评价:  / 10
好 

- 文章来自:问答专区 | 进入:讨论

问题提出:

总是报Failure [INSTALL_FAILED_OLDER_SDK]

但是,我设的

defaultConfig {
applicationId "com.name.testapp"
minSdkVersion 9
targetSdkVersion 'L'
versionCode 2
versionName "1.0"
}

而我的android设备是 4.3的系统 ,每次都编译不成功,很纳闷求解

 

问题解答:

targetSdkVersion ‘L',只能在刷了Android L Preview的机器上才能运行。

你是4.3的,很显然运行不起来。

 

当前位置:Home 文档 实战秘籍 项目不能编译,总提示设备版本过低